Prerequisites

Before installing Obcerv, you must have the following:

  1. Kubernetes cluster running version 1.18 or newer.
  2. kubectl version 1.18 or newer
    • To check this, run kubectl version.
  3. helm version 3.x
    • To check this, run helm version.
  4. The cluster must have an ingress controller installed. For more information, see NGINX Ingress controller.
    • To check this, look for its pods by running kubectl get pods --namespace=itrs.
  5. linkerd CLI version 2.9 or newer
    • To check this, run linkerd version.
  6. Credentials for the ITRS Docker Registry. Obcerv is distributed via Docker images from the ITRS registry. If your Kubernetes cluster is not permitted to access our registry, the images must be manually added to your internal registry.

You should also consult the Compatibility matrix to ensure you select compatible component versions.

["Obcerv"] ["Technical Reference"]

Was this topic helpful?