["Geneos"]["Compatibility Matrix","Technical Reference"]

Geneos 6.x Compatibility Matrix

Supported Geneos versions

ITRS supports all released versions based on the current plus the previous major versions of Geneos. Only the latest major version will receive regular fixes and enhancements. In exceptional circumstances, critical fixes may be backported to previous major versions where it is not reasonably possible to upgrade to newer versions.

The supported Geneos versions are:

  • 6.x (current major version)
  • 5.x (previous major version)
    • Some of Geneos 5.x versions may not be supported on newer platforms, databases, browsers, and applications. For more information, see the Geneos 5.x Compatibility Matrix.

Note: Upgrading between Geneos versions can introduce different changes. For more information, see the Geneos Upgrade Notes.

Important

End of life for Geneos 4.x.x is 31 May 2023. If you are using Geneos 4.x.x, we advise you to upgrade to Geneos 5.x.x or newer.

Operating system support

Operating system Versions supported
Windows

Desktop 10 and 11

Server 2016, 2019, and 2022

Linux: Red Hat

RHEL 7.x [kernel 3.10]

RHEL 8.x [kernel 4.18]

RHEL 9.x [kernel 5.14] — coming soon

Linux: Red Hat on IBM POWER8

RHEL 7.x [Little Endian] — available beginning Geneos 5.x.x versions

Linux: SUSE

SLES 12.x and 15.x

Linux: Ubuntu

18.04 LTS

20.04 LTS and 22.04 LTS

IBM AIX

7.2

7.3 — coming soon

IBM i (OS/400)

7.3, and 7.4

7.5 — coming soon

macOS

10.14.x (Mojave)

12 (Monterey) and 13 (Ventura)— coming soon

Security-Enhanced Linux

When Security-Enhanced Linux (SELinux) is running in Enforcing mode, it may deny certain functions of Geneos depending on the implemented configurations and policies.

To see which functions SELinux denies, check the audit log. The log is typically located in /var/log/audit.log, where the log type entry is AVC. The audit log provides the details of any denied access. For example, denied connection to the TCP port.

If you experience issues related to this mode, you may opt to disable SELinux, or create policy modules to grant the required access. Please contact your administrator or security team for assistance.

Geneos components

Geneos components Supported operating systems
  Windows Desktop Windows Server Linux: Red Hat Linux: SUSE Linux: Ubuntu Linux: Red Hat on IBM POWER8 (LE) IBM AIX IBM i (OS/400) macOS
Active Console (tick)       (tick)       (tick)
Collection Agent (tick) (tick) (tick) (tick) (tick)        
FIX Analyser 2 File Agent   (tick) (tick)            
FIX Analyser 2 Netprobe     (tick)            
Gateway     (tick) (tick) (tick)        
Licence Daemon     (tick) (tick)          
Netprobe (tick) (tick) (tick) (tick) (tick) Supported in Geneos 5.x version (tick) (tick)  
SSO Agent     (tick)          
Web Dashboard (Web Server)     (tick)            
Webslinger     (tick)            

Note: IBM i operating system is monitored remotely by Netprobe run on Linux operating system.

Containerised environment support

ITRS provides docker container images of the following Geneos components. Each component should meet the documented minimum operating system requirements.

Geneos Component Docker Enterprise version 18.06 or higher Native Kubernetes 1.18 or higher AWS EKS Azure EKS
Collection Agent (tick) (tick) (tick) (tick)
Netprobe (tick) (tick) (tick) (tick)
Gateway (tick) (tick) (tick) (tick)

Note: Support for the containerised environment itself or any of its services are not provided by ITRS. See the Docker and Kubernetes product documentation on how to build and manage container services.

Cloud environment support

ITRS supports running Geneos components version 4.8.0 and newer in cloud environments such as Amazon Web Services (AWS), Google Cloud Platform, and Microsoft Azure. Each component should meet the documented minimum operating system requirements.

Deploying Geneos into any cloud environments should take into consideration connectivity, performance, network traffic, and cost implications.

For more information, see Geneos on Amazon Web Services Cloud.

Plugin support

Netprobe plugins

Supported Netprobe plug-ins Supported operating systems
 

Windows

Linux: Red Hat

Linux: SUSE Linux: Ubuntu

IBM AIX

API (XML-RPC)

(tick)

(tick)

(tick) (tick)

 

API Streams (XML-RPC)

(tick)

(tick)

(tick) (tick)

 

Bloomberg B-Pipe

(tick)

(tick)

  (tick)

 

Clearvision Status

 

 

(tick)  

 

Control-M (BMC) (tick) (tick)   (tick)  

CPU

(tick)

(tick)

(tick) (tick)

(tick)

Desktop PC Monitoring

(tick)

 

   

 

Device IO

 

(tick)

(tick) (tick)

 

Disk

(tick)

(tick)

(tick) (tick)

(tick)

Dynamic Entities Health

(tick)

(tick)

(tick) (tick)  

E4JMS (Tibco EMS) Bridges

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Connections

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Durables

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Non-Durables

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Queues

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Routes

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Server

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) Topics

(tick)

(tick)

 

(tick)

 

E4JMS (Tibco EMS) User Summary

(tick)

(tick)

 

(tick)

 

Extractor

(tick)

(tick)

(tick)

(tick)

(tick)

Fidessa

 

(tick)

(tick)

 

 

Fidessa DQ

 

(tick)

(tick)

 

 

FIX Analyser 2

 

(tick)

(tick)

(tick)

 

File Keyword Monitor (FKM)

(tick)

(tick)

(tick)

(tick)

(tick)

File Latency Monitor (FLM)

(tick)

(tick)

(tick)

(tick)

 

File Transfer Monitor (FTM)

(tick)

(tick)

(tick)

(tick)

(tick)

GL Greffon

(tick)

(tick)

(tick)

(tick)

 

GL Lost Orders

Only supported on Geneos 4.x versions of the Netprobe.

GL Order Book

Only supported on Geneos 4.x versions of the Netprobe.

GL Permissions

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

GL Router

(tick)

(tick)

(tick) (tick)

 

GL SLC

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

GL SLC Relay

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

GL SLE

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

GL SLE TCP

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

Hardware

(tick)

(tick)

(tick) (tick)

(tick)

IBM i JDBC  

(tick)

(tick) (tick)  

IBM i Job

 

(tick)

(tick) (tick)

 

IBM i Log Reader   (tick) (tick) (tick)  

IBM i Message

 

(tick)

(tick) (tick)

 

IBM i Pool

 

(tick)

(tick) (tick)

 

IBM i Queue

 

(tick)

(tick) (tick)

 

IBM i Subsystem

 

(tick)

(tick) (tick)

 

IBM i System

 

(tick)

(tick) (tick)

 

IPC (Shared Memory)

 

(tick)

(tick) (tick)

 

IX Message Analyser

(tick)

(tick)

(tick) (tick)

 

JMX Server

(tick)

(tick)

(tick) (tick)

(tick)

JMX Thread Info (tick) (tick) (tick) (tick) (tick)

Market Data Monitor (MDM)

(tick)

(tick)

(tick) (tick)

 

Message Tracker

(tick)

(tick)

(tick) (tick)

 

MIB Monitor (Mibmon)

(tick)

(tick)

(tick) (tick)

 

MQ Channel (IBM)

(tick)

(tick)

(tick) (tick)

(tick)

MQ Queue Info (IBM)

(tick)

(tick)

(tick) (tick)

(tick)

MQ Queue (IBM)

(tick)

(tick)

(tick) (tick)

(tick)

NET Ping

(tick)

(tick)

(tick) (tick)

 

Network

(tick)

(tick)

(tick) (tick)

(tick)

NYXT Papastats

(tick)

(tick)

   

 

OP5 Monitor (tick) (tick) (tick) (tick)  

Oracle

(tick)

(tick)

(tick) (tick)

(tick)

Orc

(tick)

(tick)

(tick) (tick)

 

PATS Status

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

PATS Trading Breaches

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

PATS Users

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

Perfmon

(tick)

 

   

 

Processes

(tick)

(tick)

(tick) (tick)

(tick)

Publisher (tick) (tick) (tick) (tick) (tick)
REST API (Inbound) (tick) (tick) (tick) (tick)  
REST Extractor (tick) (tick) (tick) (tick)  

RMC Interface (Refinitiv)

 

(tick)

(tick) (tick)

 

SETS SLC

Only supported on Geneos 5.x versions of the Netprobe. This plugin has been deprecated on Geneos 6.x.

SQL Toolkit

(tick)

(tick)

(tick) (tick)

(tick)

State Tracker

(tick)

(tick)

(tick) (tick)

(tick)

Sybase

(tick)

(tick)

(tick) (tick)

(tick)

Sybase Server

(tick)

(tick)

(tick) (tick)

(tick)

TCP Links

(tick)

(tick)

(tick) (tick)

(tick)

TIB RV

(tick)

(tick)

(tick) (tick)

 

TIB RV Publisher

(tick)

(tick)

(tick) (tick)

 

TIB RV Stream

(tick)

(tick)

(tick) (tick)

 

Toolkit (Scripting)

(tick)

(tick)

(tick) (tick)

(tick)

Top

(tick)

(tick)

(tick) (tick)

 

Trading Technologies

(tick)

(tick)

(tick) (tick)

 

Trap Monitor

Limited

(tick)

(tick) (tick)

 

UNIX Users

 

(tick)

(tick) (tick)

(tick)

Uptrends (tick) (tick) (tick) (tick)  

Veritas Cluster Server

(tick)

(tick)

   

 

Web Monitor

(tick)

(tick)

(tick) (tick)

 

Win Apps

(tick)

 

   

 

Win Cluster

(tick)

 

   

 

Win Services

(tick)

 

   

 

WMI

(tick)

 

   

 

WTS Licenses (Remote Desktop Services)

(tick)

 

   

 

WTS Processes (Remote Desktop Services) (tick)        
WTS Session (Remote Desktop Services) (tick)        
WTS Summary (Remote Desktop Services) (tick)        

X Broadcast

(tick)

(tick)

(tick) (tick)

 

X Mcast

(tick)

(tick)

(tick) (tick)

 

X Multicast

(tick)

(tick)

(tick) (tick)

 

X Ping

(tick)

(tick)

(tick) (tick)

 

X Route

(tick)

(tick)

(tick) (tick)

 

X Services

(tick)

(tick)

(tick) (tick)

 

X Top

(tick)

(tick)

(tick) (tick)

 

X Traffic

(tick)

(tick)

(tick) (tick)

 

           

Collection Agent plugins

Collection Agent plugin Supported operating systems
 

Windows

Linux: Red Hat

AWS (tick) (tick)
Azure (tick) (tick)

Kubernetes

 

(tick)

Open Telemetry

 

(tick)

Prometheus

 

(tick)

StatsD

(tick)

(tick)

     
Collection Agent plugin version Compatible Collection Agent versions Compatible Netprobe versions

2.x

 2.x 5.8 - 5.14
3.x 3.x 6.0 or higher
     

Integrations support

Geneos integrations are configuration templates built using the core plugins for monitoring various applications and systems.

Integration Plug-ins used Requirements
ActiveMQ 3 JMX Server plug-in instances.

ActiveMQ 5.17.x

Cassandra 6 JMX Server plug-in instances. Cassandra 3.11
Citrix Vritual Apps (Formally XenApp) 4 Toolkit plug-in instances. Citrix Vritual Apps 7 2203 LTSR
CorvilNet

API plug-in

SNMP Trapmon plug-in

Corvil 9.7
Docker 2 Toolkit plug-in instances Docker 20.10.x
Elasticsearch 8 Toolkit plug-in instances Elasticsearch 8.x
Google Cloud Monitoring (formally Stackdriver) At least one Toolkit plug-in instance per monitored service. Google API Client for Python google-cloud-monitoring 2.9.x
Hadoop (HDFS and YARN)

4 JMX Server instances.

3 Toolkit plug-in instances.

Hadoop 3.3.x
Ultra Messaging API plug-in Ultra Messaging 6.13.x
ITRS Synthetic Monitoring (Apica) No longer supported. Please contact your ITRS Account Manager if you require this integration.
Kafka 4 JMX Server plug-in instances. Kafka 3.2.x
MongoDB 10 Toolkit plug-in instances. MongoDB version 5.0
PostgreSQL 1 SQL-Toolkit plug-in instance

PostgreSQL version 14.x

RabbitMQ 6 Toolkit plug-in instances RabbitMQ version 3.10.x
Terracotta Universal Messaging API plug-in Terracotta Server 5.x
Refinitiv RTDS (formally TREP)

RMC plug-in

TCP Links plug-in

Toolkit plug-in

SQL-Toolkit plug-in

Sybase and Sybase Server plug-ins

Mibmon plug-in

Trapmon plug-in

FKM plug-in

Processes plug-in

Additional licence. Please contact your ITRS account manager for more information.

Velocimetrics No longer supported. Please contact your ITRS Account Manager if you require this integration.
VMWare ESXi API plug-in ESXi 7.0.x
Zookeeper 2 JMX Server plug-in instances Zookeeper 3.7.x
     

Supported characters

All Geneos components only support ASCII characters 32-126.

Extended ASCII characters are not supported.

Database support

Database Versions Supported Database Support Notes
MySQL 5.7, 8.0

For MySQL 8.0, only mysql_native_password authentication is supported. The caching_sha2_password option is not supported.

SAP ASE (Sybase) 16.x  
Oracle

12.2, 18c, 19c

21c — coming soon

 

MSSQL Server (MS ODBC Driver 13 and 17) 2014, 2016, 2017, 2019  
IBM DB2

11.1

11.5 — coming soon

 
PostgreSQL

11, 12

13, 14 — coming soon

 
MariaDB (use MySQL configuration option)

10.3, 10.4, 10.5

10.6 — coming soon

 
     

 

Geneos component MySQL SAP ASE Oracle MSSQL DB2 PostgreSQL MariaDB
Active Console (tick) (tick) (tick) (tick)

 

(tick) (tick)
Web Dashboard (tick) (tick) (tick) (tick)   (tick) (tick)

Gateway

(tick) (tick) (tick) (tick)

 

(tick) (tick)
Plugin: FIX Analyser 2 (tick)

 

 

 

 

 

 

Plugin: Message Tracker (tick)

 

(tick)

 

 

 

 

Plugin: Oracle

 

 

(tick)

 

 

 

 

Plugin: SQL-Toolkit

  • MSSQL server is supported only for Netprobes running on Linux and Windows platforms.
(tick) (tick) (tick) (tick) * (tick) (tick) (tick)
Plugin: Sybase

 

(tick)

 

 

 

 

 

Plugin: Sybase Server

 

(tick)

 

 

 

 

 

               

Browser support

Browser Versions Supported
Chrome Latest stable version
Firefox ESR Latest extended support release (ESR)
MS Edge Latest extended stable channel release
   
Geneos Component MS Edge Firefox ESR Chrome
FIX Analyser 2 Netprobe: Show Orders Report (tick) (tick) (tick)
Web Dashboard (Web Server) (tick) (tick) (tick)
Webslinger (tick) (tick) (tick)
       

Java support

Java support is standardised among all Geneos components based on the Long-Term Support (LTS) Java versions, namely Java 8 and 11.

Lower Java versions are no longer supported, unless otherwise indicated.

All Geneos components, excepting the Active Console and Web Dashboard, are tested using the latest available stable release of OpenJDK Java 8 and 11. The Active Console and Web Dashboard are tested using OpenJDK Java 8 only.

Application and plugin specific information

Geneos Component Application Support Notes
Control-M plugin

Verified on Control-M versions 9.0.18, 9.0.19, and 9.0.20.

E4JMS (TIBCO EMS) plugins

Verified on TIBCO Enterprise Message Service (EMS) versions 8.6. (10.1.x — coming soon).

Fidessa plug-in (Users View) Fidessa plug-in uses a command line utility called netstat. On Linux this utility is part of net-tools package. By default, net-tools package is no longer included in minimal RHEL 7 + distributions. Please make sure netstat utility is available on the host where Fidessa plug-in is run.
FIX Analyser 2 plugin Requires FIX Analyser 2 Netprobe (Linux 64-bit only) with File Agents that can run on Linux, Windows, and IBM AIX for collecting FIX Logs. FIX Analyser 2 plugin tracks the state of FIX protocol version 4.2 orders.
FLM Plug-in The table below illustrates the support matrix for the different market data feeds currently supported in FLM plug-in.
Netprobe PlatformRFA (OMM)GLTTNYXT
netprobe-windows-x64(tick)(tick)(tick)

 

netprobe-linux-x64(tick)(tick)

 

(tick)

Note:

  • RFA version 8 supports the microseconds and nanoseconds timestamps that are useful for RawLatency and DataQuality solutions.
  • MDI connections on RFA are no longer supported.
Gateway Hub

Provides the support matrix for Gateway Hub, Gateway, and Active Console.

Feature Gateway Hub version Compatible versions
Anomaly Detection 1.5 or higher Gateway 4.13 or higher
Gateway Setup Editor 4.13 or higher
Centralised configuration 1.6 or higher Gateway 5.0 or higher
Gateway Setup Editor 5.0 or higher
Publish data to Gateway Hub 1.4 Gateway 4.8 to 4.13
1.5 Gateway 4.8 or higher
1.6 or higher Gateway 4.12 or higher
View data in Active Console 1.4 or higher Active Console 4.9 or higher
IBM i plugins
  • IBM i Operating system supported versions, see Operating system support.
  • IBM i Server must be IBM i, i5/OS, OS/400 V4R3 or higher.
JMX plug-ins
  • Generic connection to a JMX-enabled application is supported for Java, see Java support.
  • WebSphere connection to an IBM WebSphere Application Server is supported on WebSphere versions 8.5 and 8.5.5 and 9.0.x. It is recommended you configure Netprobe to use Java version that is packaged with your version of WebSphere.
  • WebLogic connection to an Oracle WebLogic Server is supported on WebLogic versions 12.2 and 14.1. It is recommended you configure Netprobe to use the Java version that is packaged with your version of WebLogic.
Market Data Monitor (MDM) Market Data Monitor provides feed adapter libraries used for subscribing to market data feeds. Table below illustrates the different market data feeds and their supported platforms.
Netprobe PlatformRFA (OMM)GLTTNYXTBloombergExegyQuantFeed
netprobe-windows-x64(tick)(tick)(tick)

 

(tick)(tick)(tick)
netprobe-linux-x64(tick)(tick)

 

(tick)(tick)(tick)(tick)*

Notes:

  • RFA version 8 supports the microseconds and nanoseconds timestamps that are useful for RawLatency and DataQuality solutions.
  • MDI connections on RFA are no longer supported.
MQ plugins

Verified on IBM MQ versions beginning 9.1 and 9.2 (9.3 — coming soon).

Note: This plugin only supports AIX for IBM MQ 9.1.x.

REST Extractor

Uses jq for Jackson Java JSON Processor version 0.0.9.

SSL/TLS

TLS connections are supported up to TLS 1.3.

The minimum Geneos version for SSL/TLS connections to work on RHEL 8 is 4.9.x or higher. Beginning Geneos 5.6.x, you can run SSL/TLS connections on RHEL 8 platform.

TIB RV plug-in Verified with TIBCO Rendezvous Service versions 8.2 and 8.4.5.
TCP-Links TCP-Links plug-in uses a command line utility called netstat. On Linux this utility is part of net-tools package. By default, net-tools package is no longer included in minimal RHEL 7 + distributions. Please make sure netstat utility is available on the host where TCP-Links plug-in is run.
Trapmon plug-in

The Trapmon plugin supports the following SNMP versions:

SNMP version Linux Windows
1 (tick) (tick)
2c (tick) (tick)
3 (tick)  
     

On Windows Netprobe, this plugin does not support the new MIB files, Custom View, and Clear Trap command features.

Veritas Cluster Server plug-in Veritas Cluster Server plug-in supports Symantec Veritas Cluster Server versions 6.0 and 7.0.
Web Dashboard (Web Server) There is a Web Dashboard package available without a JRE packaged. Users need to make sure Web Dashboard can access a supported JRE environment, version Java 8.
Win Cluster plug-in Win Cluster plug-in supports Windows Server Failover Clustering (WSFC) on Windows Server 2008 R2 and Windows 2012 Enterprise and Datacenter editions. 
WTS Plug-ins WTS Licenses plug-in requires Microsoft Licensing Reporter Tool (lsreport.exe) installed and functioning. This tool is no longer supported by Microsoft in Windows Server 2008 and newer. 
   

Geneos compatibility and lifecycle

This section outlines all the changes to Geneos compatibility and lifecycle. ITRS will always work with you to minimise impact of any changes, and listen to your feedback. If you have any queries, please contact ITRS Support.

The notice of change in the Geneos compatibility identifies the components, plug-ins, or features that will no longer be supported by ITRS in any future releases.

End of support notices

The end of support means that the affected component, plugin, or feature is no longer supported and this ends the release of binaries. The table below lists the affected components, plugins, and features:

Notice of change Affected components Effective date Alternative or Upgrade path
End of support for Geneos 4.x.x All Geneos components version 4.x.x 31 May 2023 If you are using Geneos 4.x.x, we advise you to upgrade to Geneos 5.x.x or newer.
End of support for Solaris operating system All Geneos components and versions 31 May 2023 Upgrade to a supported operating system.

End of releasing binaries

The end of releasing binaries means that the affected components, plug-ins, or features are no longer getting binaries for certain platforms, but the support continues. The table below lists the affected components, plug-ins, and features:

Notice of Change Affected Components Effective Date Alternative/Upgrade Path
End of releasing binaries for Linux on POWER operating system in version 6.x Netprobe version 6.x and newer

1 September 2022

Netprobe for Linux on POWER operating system is still available and supported on Netprobe versions 5.x.
       

Deprecated and removed features

This section documents any features deprecated or removed in Geneos 6.x.x versions to date, and lists any useful alternatives or upgrade paths.

Deprecated features

Deprecated features are no longer supported by ITRS, but users can continue to use them if they wish. Users should avoid depending on any deprecated features as they may be removed in any future releases.

Geneos components Affected versions Description Alternatives
Netprobe plugins
  • GL Greffon

  • GL Lost Orders

  • GL Order Book

  • GL Permissions

  • GL SLC

  • GL SLC Relay

  • GL SLE

  • GL SLE TCP

  • MISS-X

  • PATS Status

  • PATS Trading Breaches

  • PATS Users

  • SETS SLC

  • Tradeview

Geneos 6.0.0 and newer Support ended 15 September 2022. No planned replacement.
       

Removed features

Removed features are no longer supported and have been removed or disabled in Geneos.

To view the list of other features that have been removed in the past release, see Removed features in Geneos 5.x Compatibility Matrix.

Geneos components Description Alternatives

Netprobeplugins

  • Citrix Apps

  • Citrix Processes

  • Citrix Sessions

  • Citrix Summary

  • Combo

  • Component Versions

  • DQM Compare

  • DQM Updates

  • Effix Status

  • Fix Cameron Status

  • Gissing

  • RTIC Latency

  • SWX

  • Triarch Latency

  • UL Bridge

The plugins have already been deprecated and are not supported. They have been removed from the Netprobe and are not available to configure. No planned replacement.