Metrics Dockable

Overview

The Metrics dockable contains a number of metrics dataviews that are represented by a name and a tab. Each tab displays the contents of the selected metrics view.

This dockable also shows the following:

  • View selector.
  • Metric table.
  • Path to the contained dataview.
  • Search field.
  • Sampling status.

The content of the primary metrics view always follow the selection in other Active Console 2 components. It creates one metrics table for each dataview within the relevant directory component and insert it into the primary view. While, the custom metric views are manually populated. The list of dataviews do not change unless you add or remove these metrics tables from them.

There are no restrictions on the source of the dataviews that can be placed into a single metrics view. These can come from independent Gateways, and can connect to any plug-in type.

View selector

The View selector is a tree structure that consist of groups and metric tables as leaf nodes. It appears on the left panel of a metric view.

The metric tables can be grouped by a primary and secondary attribute. The attributes that can be used are:

  • Gateway — the Gateway that the dataviews within the table are contained within.
  • Netprobe — the Netprobe that the dataviews within the table are contained within.
  • Managed Entity — the managed entity that the dataviews within the table are contained within.
  • Sampler — the sampler that the dataviews within the table are contained within.
  • Sampler Group — the sampler group (as defined in the Gateway setup) that the data views are contained within.
  • Plug-name — the type of plug-in name that the connected dataviews come from.
  • None — you can negate the primary or secondary grouping by setting them to None. There are no grouping occur at the specified level. If the primary grouping attribute is set to None, then the secondary grouping attribute has no effect.

In cases where the dataviews connected to a metric table do not share a common value for a selected attribute, these belong into a group labelled Multiple. If the specified attribute cannot be located, these belong into Unknown group.

These are the available options to choose from View selector:

  • Primary and Secondary grouping — this attribute can be defined independently for each metrics view. Their current configuration is displayed at the top of the view selector.
  • Expand All or Collapse All — expands or collapses the groups available within the metrics view selector.
  • Show Root Handles — shows the +/- button that to expand or collapse the groups in the metrics view selector.
  • Allow fast Metrics Table activation — enables or disables the metrics view.

Metric tables

The view selector contains a list of metric tables. A metric table contains zero to many dataviews that are published from the plug-ins connected to the Gateways. These have two main properties:

  • Name — the name used to identify the metric table in the view selector and the viewer. By default, it takes the name of the first dataview that is connected to the metric table.
  • Paths — a set of user defined paths that determine which dataviews are included in the metric table.

A metric table has a single path which points at a single dataview. However, it is possible not only to include several paths, but to configure one or more of them to match multiple dataviews.

In these cases, the metric table may contain more than one dataview. When the metric table is selected and its contents displayed in the viewer, it shows single merged table that contains the contents of all the dataviews. This is referred to as Metric Overview Tables.

The set of dataviews connected to a metric table update as Gateways and probes come up and down.

For example, the content of metric tables is dynamic and reflects the current state at all times.

Refresh the metric table data

This feature allows you force restart the data sampling in the dataview.

The sample rate or time is also shown that can be configured in Gateway Setup Editor.

  1. Go to the Metrics dockable.
  2. Click the Sample now button.

Metric tables update automatically when the dataviews contain resampling of data.

You can also pause these updates by clicking Pause from the metric table in the viewer.

Add and remove metric tables

There are many ways on how to add or remove metric tables.

Using options from State Tree:

  1. Right-click any Managed entity or sampler.
  2. Click Create Metrics View.
  3. Select from the available settings you want to apply to your metric table.

Using options from View selector in Metrics dockable:

  1. Right-click any Managed entity or sampler.
  2. Click Create Metrics View.
  3. Select from the available settings you want to apply to your metric table.

Create Metrics View has the following options:

  • In New Dockable — opens the metrics table into a new Metrics dockable. This automatically save in the workspace.
  • In New Temporary Dockable — opens the metrics table into a new Metrics dockable. However, this does not automatically save in the workspace.
  • metricsview — opens the metrics table in the same Metrics dockable. You can select to open it on a new tab or to any existing tabs on the same Metrics dockable screen.

Another option is to drag and drop the Managed entity or sample into the Metrics dockable. This added to the currently opened metrics tab in your Metrics dockable.

Note: You can only add new metric tables to custom metrics views through drag and drop. You cannot modify the primary view.

To remove the metrics dataview:

  1. Right-click the metrics dataview from the Metrics dockable.
  2. Select Remove Metrics Table.

Note: This cannot be done within the primary metrics view.

Metric table viewer

If the metric table is displaying a single dataview, then the headlines for that dataview are displayed above the table in a series of horizontally ordered boxes.

If the metric table has more than one dataview, then the headlines are displayed in another table. This includes columns detailing the Gateway and managed entity the headline is applicable to, so that you can tie specific headlines to specific dataview instances that make up the metric table.

Configure the column headings

The columns in metric tables allows you to:

  • Reorder and sort the column headers through drag and drop.
  • Set the column size or auto-resize all columns.
  • Hide and show the specific column header.

These settings are save for as long as the metric table exists in the view selector.

Note: The first column of a metric table is treated as a special column that cannot be hidden. Once resized, it does not occupy more than a third of the viewable screen. If any value of a first column cell is longer than this limit, use a tooltip to view the full value.

You can choose to save the settings as the default for all metrics tables of the same name.

To save this setting, go to the metric table:

  1. Right-click any column header.
  2. Click Column settings.
  3. Select Save as data view defaults.

Alternatively, you can save the column settings selectively by using the Table Column Settings Editor. This dialog is accessible on the same menu when you right-click any column header.

Whenever a metric table with a dataview of the same name is created, the default column settings are applied. However, any existing metric tables are not affected.

Warning: The primary metric view constantly refreshes its content based on user selection. Do not spend too much time setting up table layouts here, as these will be lost as soon as there is a new user selection in another AC2 component. You can define dataview default settings here that can be saved.

To revert the changes made to dataview default setting, go to the metric table:

  1. Right-click any column header.
  2. Click Column settings.
  3. Select Revert to data view defaults.

The other option is to revert any modified settings to factory defaults by clicking to Column settings > Revert to Factory Settings.

This setting loses any modified settings in favour of factory defaults, but no changes are applicable to the workspace. Therefore, when the dataview is loaded next time, the workspace default is automatically applied.

This status button is available to you on the metrics table filters bar next to Pause and Sample now buttons. It has the following features:

  • Current Settings Persistence Status — if you have any settings saved in the workspace for the metrics table, the icon on the button turns blue. If you do not have any settings, then the icon stays dimmed.
  • Table Column Settings Editor — open this to view and manage the table column settings.

ac2-user-guide83

Sampling information label

This label is available on the Metrics dataview next to the Table Column Settings Editor button. This label contains comma separated literal values for rows, sampling interval, manual sampling time stamp, last sample time stamp, and list of hidden columns.

This automatically changes when you click the Sample now command that is used to update the current metrics view.

The Last sample value displayed in the dataview is the Sample Time value of the Netprobe:

4 rows, Sampling every 20 seconds, User requested sample completed at <local AC2 time>, Last sample <Netprobe Last Sample Time>

Note: If the sampling information label does not display the sample time, then Active Console 2 is not receiving an event to trigger an update for the current metrics table.

Status of hidden columns

The status bar displays a list of column names that are currently hidden from the table. This hidden column information is independent of any persisted table settings. If there are hidden columns, these are listed here.

Note: The exception to this rule are columns whose name starts with a '/'. These are hidden by default, and therefore their hidden status is not reported on the status bar.

Active and inactive metric tables

You can make metric tables active and inactive. This is useful if you have large scale metric overview tables that you only need by the time you query them.

Caution: Metric tables can be exhausting in terms of memory and CPU usage. You may consider making them inactive when not in use.

To do this:

  1. Right-click the selected metric table or the selected Managed entity/sampler in the View Selector.
  2. Select Active.

Inactive metric tables contain no dataviews. Once activated, the dataviews return in metrics table.

Inactive dataviews are shown with a blue x icon and displays this message:

The metrics table is inactive.

Save metric tables as CSV

You can make an output of metric tables that saves the table to a comma separated (.csv) file:

  1. Right-click the selected metric table.
  2. Select Save As CSV.
  3. Type the filename in the File name field.
  4. Click Save.

You can also use the Copy Dataview option that places the non-filtered table contents into the system clipboard.

Query the metrics table

You can perform a simple query function that can be performed on metric tables.

Count Unique is used to count the number of unique names or values in a given column.

To use this method, follow these instructions:

  1. Right-click the selected metric table.
  2. Click Query Table.
  3. Select Count Unique.
  4. Click OK to close the dialog box.

Success: The results of the selected parameter with unique values show in a dialog box.

Configure metrics filters

You can add filters to any metric table to restrict the rows that are displayed based on criteria.

To use this method, follow these instructions:

  1. Right-click the selected metric table.
  2. Click Filter Table.
  3. Click the add button to specify the metric filters.
  4. Click OK to save the changes.

A row is only displayed if it passes all the filter conditions. Each filter has the following attributes:

Field Description
Column

The column whose row value must pass the filter.

There are also special cases for ANY COLUMN, where 1 or more cell values in a row must match the criteria.

Or ALL COLUMNS, where all row values must match the criteria.

Not A Boolean flag check box that inverts the criteria.
Value Value to match against.
Operator

A series of logical operators that determines the relationship between a successful match and the value specified in the value column.

  • Contains — matches if the value of the specified column contains (case sensitive) the value defined.
  • Contains No Case — matches if the specified column contains (non-case sensitive) the value defined.
  • Equal — matches if the specified column is the same with the specified value. This is a literal string equality (case sensitive).
  • Equal No Case — matches if the specified column is the same with the specified value. This is a literal string equality (non-case sensitive).
  • Less than — matches if the specified column is less than the specified value.
  • Greater than — matches if the specified column is greater than the specified value.
  • Numeric Equals — matches if the specified column is the same with the specified value. as a mathematical equality.
   

If a metric table has an active filter, then a yellow banner appears on the metrics table that displays the number rows and filters applied:

Filters persist for the life time of the metric table and between AC2 sessions. Therefore, it is possible to add two metric tables to a metrics view which have the same path attributes (and therefore contain the same data views) because you can set up different filters on these tables.

To remove the filters, follow these instructions:

  1. Right-click the selected metric table.
  2. Click Clear filters.

Create a metric overview

To create a Metric overview in Active Console 2, either you:

  1. Click Tools > Create Metric Overview in the Menu bar.
  2. Click the Create a new Metrics Overview Table button in the Toolbar.

This allows you to specify a data viewname, a target metrics view, and whether to filter the dataviews on the current state tree selection.

A metrics overview is created with the relevant metrics view that contains all dataviews of the specified type currently connected to the Active Console 2, in the specified section of the State Tree.

The Metrics Overview screen has the following options:

Field Description
Dataview attribute Defines which attribute of dataviews is used to populate the list and subsequently used to populate the overview.
Dataview name

A list of all the unique names of the dataviews you are currently connected to through the Gateways.

You have to select one or more of these before clicking OK (Hold down the CTRL key to make a multiple selection).

Also, you can double-click an item from the list to save than having to click OK. However, this limits the selection of one dataview type.

Metrics view The target metrics view that you want to insert the new metrics overview into.
Limit on the current state tree selection

Limits the dataviews that are selected to go into your new metrics overview based on the current selection in the State Tree.

For example, only dataviews that are children of the currently selected state tree node are selected to go into your metrics overview.

If you turn this off, then the state tree selection is ignored and all dataviews with the specified name are inserted into the State Tree.

Default: On

   

Select the persistent overview option

This changes the default behaviour to close the Metric Overview dockable when the window is closed.

In addition, this adds the Persistent overview check box in the overview metrics wizard which was initially turned off.

  1. Select the Dataview Attribute and the field you want to view.
  2. Select the Persistent overview check box.
  3. Click OK.

Success: The New Overview Dockable displays on the screen.

Export and import metric views

You can export a metrics view (one of the tabs) to a file that can then be imported into another workspace:

  1. To export, right click in the view selector and select the export function.
  2. To import, go to File > Import.

Table column settings editor

The Table Column Settings Editor configures the table settings in the Metrics view.

To open this editor, follow these steps:

  1. Right-click any data item in the Metrics view.
  2. Select Column Settings.
  3. Click Table Column Settings Editor.

Note: If you open this editor through Tools > Table Column Settings Editor, the Active Console 2 leads you to an empty view. Check that a cell or data item is selected from the Metrics view before you use this.

Configure the table column settings

For each column in the table, the following column settings can be saved:

  • Visibility — displays the column.
  • Position — sets the order of the columns, where the leftmost column uses the index 0, and the rightmost column uses the X-1, where X is the number of columns.
  • Width — width of the columns,in pixels.
  • Sort Order — the sort order has two parts: the order, which is an index, and the direction, which can move up (sort ascending), or move down (sort descending). Since multiple columns can be sorted, the index refers to the priority of the sorting. For example, the data is first sorted on the column with sort index 0, and then, if there are duplicates, the data is sorted by the column with sort index 1 and so on.

You can also review, change, or remove any previously saved settings for all tables. If you remove saved settings for a table, then the system automatically resets itself to factory settings for that table. Different operations are associated with each type of settings that can be saved, such as:

  • Highlighted cells in yellow contain settings that the workspace saves.
  • Highlighted cells in gray represent the current table settings.
  • Hiding a column disables the properties.

The Remove Persisted Settings, which is located at the bottom of the editor, can be used to remove all modified column settings for the selected dataview entry.

Edit columns properties

You can manipulate the column headers to change their properties. Right-click the specific row in the table for more options:

  • Selected Cells — manipulate settings for all selected cells. To select multiple cells, press and hold CTRL while selecting the cell you want to configure.
  • Current Cell — applies changes to the selected cell.
  • Current Column — the column which the current cell belongs to.
  • Current Row — defines the current settings for all table columns.

The Table Column Settings Editor can only be configured properly when you right-click a cell in the Metrics dockable.