Geneos ["Geneos"]["Release Notes", "Known Issues"]

Geneos 6.x Known Issues

Overview

Geneos known issues contain a list of bugs and issues that may affect the performance of your applications and components in Geneos 6.x. To view the reported and resolved known issues for Geneos 5.x, see Geneos 5.x Known Issues.

ITRS works on isolating and fixing every product issue that we are aware of. We categorise a bug or an issue as a known issue if it meets the following criteria:

  • The issue is reported by multiple users or is likely to have a high impact.

  • The users should be aware of to minimise any disruptions to their monitoring.

  • It is a critical issue, or with a high severity security vulnerability risk.

The Reported version is also provided for each known issue which indicates the Geneos version where the issue was found. However, these issues may be valid across multiple versions.

This list is always updated regularly, and issues that are resolved will be added in the Geneos release notes.

Important

End of life for Geneos 4.x.x is 31 May 2023. If you are using Geneos 4.x.x, we advise you to upgrade to Geneos 5.x.x or newer.

Geneos release notes

For detailed release notes for the latest version of Geneos, see Geneos 6.x Release Notes.

Geneos follows a two-month release cycle. The next planned release for Geneos 6.1.x is November 2022.

Upgrade to Geneos 6.x

If you are upgrading from an earlier version of Geneos, please read Geneos Upgrade Notes for compatibility changes you should be aware of before upgrading.

Open known issues

This section provides the list of known issues affecting this release, and are currently being investigated.

Issue key Affected component Reported version Known issue description
VI-9496 Web Server Geneos 5.14.x

A security vulnerability CVE-2016-1000027 has been identified, affecting the Pivotal Spring Framework library that is used in the Geneos Web Dashboard (Web Server) component. However, Web Dashboard is not impacted by this vulnerability based on the information mentioned in CVE-2016-1000027.

Note: The vendor is unlikely to provide a fix for this specific vulnerability or to change the current behaviour of the product because some users rely on deserialization of trusted data.

UTL-1135 Gateway, Netprobe Geneos 5.1.x

Gateway and Netprobe are unable to use MySQL 8.0 client libraries in SLES12.

Workaround:

Revert to libmysqlclient.so.18 client libraries.

       

Resolved known issues

This section provides the list of known issues that have been resolved in Geneos 6.x. The resolved known issues are added in the Geneos 6.x Release Notes.

Issue key Affected component Reported version Known issue description Fix version
VI-9368 Active Console Geneos 5.10.x

List Views in the Active Console may cause performance issues where they contains non-identifying predicates in the X-path. Active Console may drop Gateway connections when a large number of Gateways are connected.

Upcoming releases will help you identify and fix these X-paths to improve performance. As a workaround, we recommend a manual fix for any of your existing workspaces. Please refer to the Refactor List Views containing XPaths with Non-identifying Predicates article.

Geneos 6.0.x